Back to overview
DNS Failure
Mar 6, 2026 at 10:56am UTC
Affected services
Website Status
Resolved
Mar 6, 2026 at 10:56am UTC
DDoS attack to the website DNS provider. Should be solved now.
Affected services
Resolved
Mar 6, 2026 at 10:56am UTC
DDoS attack to the website DNS provider. Should be solved now.
Affected services